SharePoint

Unique (or not) Document ID

In my records management presentation at SharePoint Fest yesterday I touched on the new document ID feature in SharePoint 2010, basically just pointing out that the Feature is activated at the site collection level and there is a farm level job that runs to assign ID’s to existing docs. Later in the day I had a conversation with a couple attendees regarding the uniqueness of these IDs and whether they were truly unique across the farm. My experience had shown them to be unique, but there was conflicting info.

So I did some research and played around some more to see how unique they were. I found this post on non-uniqueness and followed his example to try to duplicate what he was seeing. I didn’t see the same results, though. No matter what I did I wasn’t able to get two documents with the same ID. For my example, I used the prefix “TEST” and then let SharePoint take over from there. The first site collection used “TEST-6-xxxx” for it’s IDs and the second used “TEST-2-xxxx”. I created a bunch of documents in both locations and each location stuck to it’s unique prefix. I moved documents around using a custom Send To location and they kept their IDs as they moved. All expected.

Now I’m stumped. Perhaps I’m running a newer CU that fixes the issue that others have seen (I haven’t looked at the CU fix list yet), or maybe I’m doing something wrong to reproduce. Please leave a comment if you are seeing different results or have some other insight.

Maybe just to be safe, make sure you use a unique prefix in each site collection. Winking smile

SharePoint, Technical

SharePoint Fest Records Management Presentation

Thanks to everyone who attended my session this morning! It was a great turnout and we had some good questions and discussion. Enjoy the PowerPoint, and ping me if you have any follow up questions. I’m always available!

SharePoint 2010 Records Management