Office Web Apps, PowerShell, Technical

Prereqs for Office Web Apps Server 2013

Just a quick programming note for our home viewers installing Office Web Apps 2013 on Windows 2008 R2. If you’re following the instructions on TechNet, they list the following prereqs as of the writing of this post:

  • Windows Server 2008 R2 Service Pack 1
  • .NET Framework 4.5
  • Windows PowerShell 3.0
  • KB 2670838

image

Ignore that last one. Another prereq that OWA checks when you try to create a new farm running New-OfficeWebAppsFarm is for KB2592525, although the TechNet article doesn’t mention that. If you install 2670838 and then try to install 2592525, you’ll get a message stating that the update doesn’t apply, so you aren’t allowed to install the update and can’t create your OWA farm.

If you did install 2670838, just uninstall it and you’ll be good to go.